Resolved: US Visualization Hosts Intermittent Outage

Incident Report for Logit.io

Resolved

Between 13:10 UTC and 13:57 UTC on November 10, our US visualization services (Kibana, Grafana, Jaeger) experienced intermittent connectivity issues due to instability within our Kubernetes cluster.

Total outage time: approximately 23 minutes and 20 seconds.

The issue was resolved by performing an ETCD backup restoration, and all services have remained fully operational since 13:57 UTC.

This incident was isolated to the US region, and no other services were impacted.
Posted Nov 10, 2025 - 14:00 UTC