Connectivity issues within our US Region

Incident Report for Logit.io

Resolved

This incident has been resolved.
Posted Apr 21, 2026 - 19:19 UTC

Monitoring

We are seeing active recovery, we are monitoring
Posted Apr 21, 2026 - 16:46 UTC

Update

We have a restored access, we continue to work on brining back full availability
Posted Apr 21, 2026 - 16:37 UTC

Update

We are rebuilding some infrastructure while our service provider continues to fix underlying issues
Posted Apr 21, 2026 - 16:22 UTC

Identified

Posted Apr 21, 2026 - 15:47 UTC

Update

We are continuing to investigate this issue.
Posted Apr 21, 2026 - 15:45 UTC

Investigating

We are currently investigating this issue.
Posted Apr 21, 2026 - 15:45 UTC
This incident affected: US Region (Visualisation Hosts, Grafana® Hosts).